SNES - SNS-CPU-GPM-02 (1993) - Black screen after recap

Author Topic: SNES - SNS-CPU-GPM-02 (1993) - Black screen after recap  (Read 540 times)

Loom

  • Newbie
  • *
  • Posts: 2
  • Newcomer
SNES - SNS-CPU-GPM-02 (1993) - Black screen after recap
« on: April 13, 2023, 09:19:22 PM »
Hello and thanks in advance for any help diagnosing this issue.

The AC input on my snes needed repair so I decided to take the opportunity to recap the board while I had the entire thing apart and the solder tools ready to use. I have experience with the recapping process, and everything went perfectly. I also replaced upgraded to the L78S05CV. I would check the system periodically on the way to make sure things were working as I went. I finished up the last cap and everything continued to work as normal. The only issue I had was my flux pen exploded in the middle of the process and made a huge mess on the board. So at the end I decided to give the board a good wash with soap and hot water, and a final rinse / bath in some 99% ISA. I have done this process many times before with other projects and did not think much of it. After thoroughly drying it with compressed air I gave it a good test and was greeted with a black screen. Composite sync seems to happen with the TV, but there is no sound or graphics with any known working cartridges I have tried.

Definitely a bummer moment for me, and I have spent hours now trying to figure out what went wrong. It was a sticky mess, but I would rather have sticky than a non-working console. I feel comfortable working / soldering as I have a good amount of experience but full diagnosing a console like this is pretty new. I was able check with a multimeter to make sure all the power was delivering correctly through the console and to the cartridge and everything was reading a steady 5v so I spent some time touching up any obvious dry solders with no success.

Hours later I have slowly and very carefully touched up pretty much every pin on the entire board, saving all the PPU and CPU for last. I triple checked everything for any bridges and everything looked perfect and clean but no issues. I did find a resistor, I think R98 that was off its pad on one side, other than that everything seems to have a solid solder joint.

I have been reading about how prone to failure the proprietary parts are for these, and knowing that now I probably would have never done a full wash like I did, but I still find it a little hard to believe that they are totally dead. The only diagnostic test I have available at the moment is with the sd2snes. I think most the this test is for the sd2snes, but I am hoping it might provide some clues on where to look next.

===log opened===

derp

SD test... please insert card

=============================

data=111133b04504

crc1 = d805a1bf crc2 = d805a1bf PASSED





RTC Test

========

setting clock to 2011-01-01 00:00:00

2011-01-01 00:00:00

waiting 5 seconds

new time: 2011-01-01 00:00:05

PASSED





FPGA test

=========

configuring fpga...

fpga_pgm: 212501 bytes programmed

FPGA configured

basic communication test...PASSED





RAM test

========

Testing RAM0 (128Mbit) - clearing RAM - writing RAM - verifying RAM -RAM0 PASSED





Testing RAM1 (4Mbit) - writing RAM - verifying RAM...RAM1 PASSED





SD DMA test

===========

clearing RAM - loading test file - verifying -PASSED





Loading SNES test ROM

=====================







sysclk test

===========

measuring SNES clock...

21477332 Hz

21477332 Hz diff = 0 max = 0

21477331 Hz diff = 1 max = 1

21477331 Hz diff = 0 max = 1

CPUCLK: 3172450

READCLK: 1812829

WRITECLK: 453207

PARDCLK: 0

PAWRCLK: 0

REFRCLK: 78726

ROMSELCLK: 453207

PASSED





SNES test status: IRQ: 00 PA: 00 MEM: 00/00

Timeout! SNES appears to be dead!







TEST SUMMARY

============



flash check: 1111-4-33b04504-dfb09a7f-08-11-0

Test Result

----------------

SD Passed

USB not implemented

RTC Passed

CIC no run

FPGA Passed

RAM Passed

SD DMA Passed

CLK Passed

DAC not implemented

SNES IRQ FAILED

SNES RAM FAILED

SNES PA FAILED



The sysclk and CPU test seems to pass, but seems to have different results when I run it. My first several tests only showed the CPUCLK and REFRCLK, but after touching some things up I seem to more consistently get the results I posted. I have at least once seen the PARDCLK activate, but not the PAWDCLK. The IRQ, PA, and MEM have consistently shown 0.

Any insight would be appreciated.

Jade

  • Member
  • **
  • Posts: 25
  • Traveler
Re: SNES - SNS-CPU-GPM-02 (1993) - Black screen after recap
« Reply #1 on: April 13, 2023, 10:51:00 PM »
If I were you, I'd get one of those new (cheap) Oscilloscopes and follow the signal. I think it's the only way you're going to pinpoint exactly where the problem is without just stumbling upon it. This happens with the Super Nintendo more than you would think. If I had to guess, seeing how you're pretty much redone the board, is that it's in the CPU chip. Reading a lot, I see where when this happens, and you've replaced all the capacitors, and there are no trace breaks, it's usually the CPU chip. Many people have replaced the CPU from a donor board and the SNES works great again. I know it's hard to believe it's the CPU (or even the PPU), but it happens. Those SNES chips were notorious for failures.

Loom

  • Newbie
  • *
  • Posts: 2
  • Newcomer
Re: SNES - SNS-CPU-GPM-02 (1993) - Black screen after recap
« Reply #2 on: April 13, 2023, 11:23:20 PM »
Thanks for the fast reply. Yes I have pretty much accepted that it could be a failing CPU at this point. It is quite unfortunate as it makes me worry that this will just continue with all snes and they will become incredibly rare.

Funny that you mention the oscilloscope, I was just checking some out and was going to do some research on what would be the most appropriate. I am not losing hope yet on it, but I agree that I probably wont be able to verify with any certainty unless I can actually check activity on data lines. I think either way I will be on the lookout for an inexpensive donor board or a backup replacement in the mean time.